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Introduction

Introduction

This document presents the software release documentation for the Seafloor Information
System, SIS version 3.7 build 92.

It is released for the following platforms:
• Operator station:

– HWS
• Operating systems:

– Windows XP Professional with Service Pack 3 and all relevant patches installed.
On a few HWS11 units problems has occurred with Service Pack 3. HWS11 units
with all Windows updates installed works fine.

• Database server:
– SIS works with PostgreSQL version 8.3 and 8.2 on XP. Installations using

PostgreSQL 8.2 are not updated to PostgreSQL 8.3.
Note

THIS RELEASE DELETES THE ODBC CONNECTION TO THE DATABASE
SERVER USED BY SIS 3.5 AND EARLIER VERSIONS. A NEW ODBC
CONNECTION TO THE NEW PostgreSQL DATABASE SERVER IS CREATED.
THE CONTENT OF THE OLD DATABASE IS THUS INACCESSIBLE BY SIS 3.6
AND LATER VERSIONS.

After installing SIS 3.7 and if you want to revert back to SIS 3.5 or earlier, please
follow the instruction in the SIS installation procedure on how to remove SIS and
uninstall PostgreSQL.

The installation of Operator software should be done in accordance with the updated SIS
Software installation procedure, reg. number 851-164891, Rev. N.

The Operator manual, reg. number: 850-164709, has been updated for the SIS 3.7
release.

Note

Note that some SIS features will require a hardware licence dongle.
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Note

If the system is operated continuously with unattended hardware errors, SIS may
experience a gradual degradation of responsiveness due to an increased error handling
load.

(Hardware errors are normally indicated by orange or red status lamps in the SIS main
menu bar as well as detailed error messages in the Message service frame.)
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Documentation

Documentation

Note

All documents have been updated for the SIS 3.7 release.

• Online help is implemented in English only.
• SIS Software installation procedure Document registration number: 851-164891,

Rev N.
• SIS Operator manual Document registration number: 850-164709, Rev. H.
• SIS Reference manual for EM 120, Document registration number: 337678, Rev. B
• SIS Reference manual for EM 122, Document registration number: 337679, Rev. B
• SIS Reference manual for EM 300, Document registration number: 337696, Rev. B
• SIS Reference manual for EM 302, Document registration number: 337734, Rev. B
• SIS Reference manual for EM 710, Document registration number: 337660, Rev. B
• SIS Reference manual for EM 1002, Document registration number: 337745, Rev. B
• SIS Reference manual for EM 2000, Document registration number: 337751, Rev. B
• SIS Reference manual for EM 2040, Document registration number: 342682, Rev. A
• SIS Reference manual for EM 3000, Document registration number: 337759, Rev. B
• SIS Reference manual for EM 3002, Document registration number: 337815, Rev. B
• SIS Reference manual for ME 70, Document registration number: 337821, Rev. B
• EM Series datagram formats, Document registration number: 160692, Rev M
Note

The SIS operator manual in an excerpt of the SIS Reference manual. System parameter
options and technical references are not described in the operator manual, whereas the
SIS Reference Manual contains full documentation of SIS and parameters for mentioned
system.
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Software installation

Java
SIS 3.7 require Java version 1.6. Any earlier version of JAVA has to be manually
removed before SIS is installed. Java installation is started automatically at installation.

Windows
Remote Helmsman running on an external PC requires that the Windows firewall is
turned off.

If autorun is not started, start setup.bat.

Please see the Installation Procedure for details.

The install procedure displays SIS version and compilation time. The release date is
shown when choosing About SIS from inside SIS.

SVP Manager
The MDM SVP Manager, a tool for transferring SVP Profiles from various sensor types
to different receivers such as echo sounders and acoustic position systems, is included on
the distribution CD. See the folder SVPMan on the CD for documentation in the file SVP
Manager.pdf. Installation is started by double-click the SVP Manager.msi file.
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SIS software release 3.7

Overview
This SIS version can be used in combination with the echo sounders with which it was
released.

In addition the Single Beam interface using NMEA datagrams has been verified.

This version is released for Windows XP only.

Software changes since SIS 3.6

Database
SIS 3.7 is released with PostgreSQL version 8.3 on the Windows XP platform. Old
databases predating SIS 3.6 will not be used or converted to PostgreSQL. Remember to
save the PU parameters before earlier versions of SIS is uninstalled.

All settings in the SetParameters and External sensors menu is now retained when the
database is updated.

Support for new EM 2040
The set of supported echo sounder types has been extended with the new EM 2040 type.
This echo sounder has one TX transceiver and one or two RX transivers (RX1 and RX2).
In a three headed configuration RX1 is the port head and RX2 is the starboard head.

The handling of the EM 2040 echo sounder is similar to the existing echo sounders, i.e.
the configuration and control is performed by using the Installation and Test, the Runtime
parameters and the Runtime param. Mini frames.

Compared to the existing echo sounders the following new configuration and status
elements have been added:

• Configuration of one additional head (in a three head configuration), i.e. location and
angles in the Installation and Test and Runtime parameters frames.

• Pulse type selection (CW or FM) in Runtime parameters→Sounder Main
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• Absorption coefficients for new frequencies (200kHz, 250kHz, 350kHz, 400kHz in
addition to the existing) in Runtime parameters→Filter and Gains

• A new status element Head used in the Numerical display frame
• The receive heads (RX1 and RX2 in a three head configuration) may be turned on

and off independently in the Runtime parameters→Sounder Main and in the Runtime
param. Mini frames. (This is the same as for the EM 3002 echo sounder).

The File menu
1 A user comment can be added to an exported PU parameter file.

When exporting PU parameters (File→Export PU parameters...) a pop-up will be
displayed containing a text entry field. The user may in principle enter an unlimited
amount of text using the contained editor commands. Note that no graphical
information or pictures may be added or included.
The OK button is used to complete and accept the entered text. The text is stored on
file together with the PU parameters.
If the user opt to save the PU parameters without any comments or discard any
entered text the Cancel button must be used.
The user comment will be saved in the heading of the PU parameter file enclosed in
’User comment’ brackets. This will enable easy reading of the user comments as
well as use of standard retrieval functions when importing the PU parameter file.
The latest saved or latest imported text will be shown as default in the text entry
field on the next subsequent ’Export PU parameters’ operation.
The following editor commands are available in the text entry field (Windows
compatible):
• Enter: Insert line.
• ctl+C: Copy the marked text.
• ctl+V: Paste copied or cut text.
• ctl+X: Cut marked text
• Bakspace: Delete character to the left.
• Del: Delete character to the right.
• Insert: Toggle insert on/off
• Drag mouse cursor to mark text or alternatively: Shift+arrow buttons to

mark/un-mark text.
• Home and End: Move cursor to the start and end of line, respectively
• ctl+Home and ctl+End: Move cursor to the start and end of buffer, respectively
• PageUp and PageDown: Move cursor one page up and down.
Note that no undo, redo or search commands are currently available

2 The PU parameters can be set to factory default values.
The currently selected echo sounder (PU) can be reset/restored to its original
factory default parameter settings by selecting File→Set PU factory settings... The
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PU parameters included in this operation comprise the installation and runtime
parameters.
When this feature is selected a pop-up is displayed asking the operator to confirm
the operation due to the possible extensive parameter changes. If the operator
cancels at this stage no further action is taken. If the operator selects to continue
another pop-up is displayed where the operator can change the serial number (i.e.
same procedure as when importing previously exported PU parameters). The
operator may also opt to cancel the whole operation at this stage by selecting the
Cancel button.
The factory default parameter values are defined independently for each type of
multi beam echo sounder. The parameters are stored in a file of the same format as
used by the Export PU parameters... and Import PU parameters functions. However,
it is not the intention that these files should be changed by the operator implying that
no export facility has been provided for these parameter settings.
WARNING

When the reset/restore operation has been completed
successfully the factory default parameters for the selected
echo sounder have been stored in the SIS database, but the
parameters have not yet been transferred to the PU. The
parameters are transferred to the PU only when the echo sounder
is started or when the OK button is pressed in the Installation
and Test window.

3 Remove echo sounder from the SIS database.
All echo sounders on the network, detected by SIS during SIS start-up or Rescan,
will be instantiated and permanently registered in the SIS database. This mechanism
has been additive only, meaning that it has not been possible to remove or delete
any obsolete or unwanted echo sounders. Usually this has not been a problem as
only the currently detected echo sounders (i.e. ’live’ echo sounders) are displayed
at start-up or after a Rescan. However, there have been some exceptions to this
rule. E.g. in the datagram distribution function, see Tools→Custom...→Datagram
distribution, all registered echo sounders in the database are displayed, i.e. both
currently and previously detected.
To be able to clean up and remove any obsolete or unwanted echo sounders from the
system a new user selection has been added to the File drop-down component in the
GUI Main Menu, i.e. File→Remove Sounder from Database.
When selecting this item a new list is displayed containing all registered echo
sounders that are eligible for deletion:
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Note that it is not allowed to remove the currently displayed (active) echo sounder
or any started echo sounders so these will not be included in the list. When the
operator makes a selection in the list a confirmation is required before the removal
of the echo sounder will proceed.
Surveys, logged data or any stored PU parameter files etc. belonging to the removed
echo sounder will not be deleted.

The View menu
Tear Off Menu. The Manage Windows menu has been replaced by a Tear Off menu.
The Tear Off menu provides a list of frames that can be opened in a ’tear-off’ window.
Select one of the frames to open the selected frame in a new ’tear-off’ window. This
functionality replaces the functionality provided by the ’New’ button in the old ’Manage
Windows’ dialog. The remaining functionality from the ’Manage Windows’ dialog
is no longer supported.

Numerical display frame
1 The list of available items is now sorted alphabetically in the current language.
2 Monitoring of PU motion sensor input frequency.

The PU must receive motion sensor input with a sufficiently high update rate to be
able to produce depth information etc. of an acceptable quality. If the movement of
the ship is not properly compensated for when a ping is processed the generated data
will be of poor quality or rendered useless.
SIS will therefore monitor the received motion sensor input rate and generate
warning information if it is below a preset frequency. The warning will be in the
form of a yellow background in the motion related display items (Roll, Pitch and
Heave) in the Numerical display frame:
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The PU Status Lamp in the Toolbar will also be yellow. In addition a warning will
be generated in the message system to the same effect (see the Message service
frame). Note that no pop-up is displayed for this problem.
This frequency monitoring is only performed for the active motion sensor.
The predefined minimum motion sensor input frequency can be changed by using
Tools→Custom...→Set Parameters →Sensor options

The minimum motion sensor input frequency is set to 90Hz by default.
3 FM mode in Numerical display.

The FM transmit mode can now be displayed in the Numerical display. This mode
information is valid for the following echo sounders only:
• EM 122
• EM 302
• EM 710
• EM 2040
The status information may have one of the following values:
• CW (Continuous Wave)
• Mix (using both CW and FM)
• FM

Geographical window
1 Point Data. Display of Point data is corrected and now the point data is displayed

with the same depth variable as the grid.
2 Grid Color value, Points per Cell in the Geographical options menu. If the user has

set SIS to store all depth in the grid the correct value is now returned. Before a
maximum of 25 was reported.
When the user zooms out the number of points per cell increases as the display grid
changes level of detail.

3 Update of the real time depth tail for echo sounders operating in dual swath mode.
The real time depth tail is updated at a maximum rate of 2 Hz. Now both swaths are
included when the echo sounders is operating in dual swath mode.
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4 Renaming in the Geographical Option, Sonar Display Grid menu. A more clarifying
text is used in the Grid Size field, Maximum Number of Cells is now denoted
Maximum number of processing grids. The actual size of a processing grid is set
in the Grid Engine Parameters menu in either New Survey, import of raw data and
survey templates where Number of cells in processing grid and the cell size is given.

5 Plotting sound speed at transducer in the geographical window

Figure 1 Displaying the sound speed at the transducer head in GeoView

The command line program makeSoundSpeedAtHeadFile.bat can be run
from a command window like this:
makeSoundSpeedAtHeadFile.bat c:\sisdata\raw\surveyname

The program has one command line parameter, which is the complete
path to the raw data folder where the .all-files are located.
makeSoundSpeedAtHeadFile.bat will search for all files of
type .all from the given directory and output the file soundspeed.txt to the
current directory.
Then open Tools→Custom...→Create grid from ascii-files and select soundspeed.txt
as the ascii file to create grid from. Note that the grid cell size should be much
larger than for a “normal” survey.
SIS will not understand that the contents is sound speed, so SIS will display
Depth in the legend.
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It may still be difficult to see a terrain model of these data because there are only
one measurement at the ship’s position, so i may be better to display the grid as
points rather than grid to see the values.

6 Grid Transparency. A different type of transparency is now used for the survey grid
in the Geographical View. The display of areas where transparent grids overlap and
areas where grids overlap a background image has been improved.

7 COG Vector for Ship. It is now possible to display a Course Over Ground (COG)
vector for the ship symbol in the Geographical View. The length of the vector can
be set in minutes (i.e. the end of the vector will be a specified number of minutes
away, based on current COG and SOG).

8 Restricted Region. If the displayed region of the survey grid has been restricted
by the region restriction feature, an rectangle will be displayed in the GeoView
showing the region within which the grid has been restricted. This is especially
useful in cases where the restricted region does not contain any gridded data.

9 GeoTIFF File Output. It is now possible to output the gridded survey data shown
in the geoview to a GeoTiff file. A toolbar button has been added to the GeoView
toolbar. When the toolbar button is pressed, a GeoTiff file is created (by default,
in the sisdata/common/background directory) showing the displayed gridded data.
Real-time depths, shipstrack, coverage, the ship symbol, the graticule, and the color
scale are not included in the GeoTiff file.
Three files are created; a geotiff file named gvosr.tif, a normal tiff file named
gvosr_tmp.tif, and a tiff world file with georeferencing information for the tiff file
named gvosr_tmp.tfw.
A batch file named geotifcp.bat is used to create these files. This allows some
possibility for minor user customization such as moving or copying the files after
they are created.

10 Transparency on White Background. A transparent grid will now be displayed
correctly on a white background (and on background images with white portions).

11 Auto ’True Point’/’Center Point’ Selection. When selecting the draw style for
the grid, triangulation is automatically set to ’True Point’ when Points or Lines
is selected, and automatically set to ’Center Point’ for all other draw styles. The
’Advanced Options’ menu has been eliminated.

12 Auto ’Zoom to World’. ’Zoom to World’ is automatically executed each time a
new survey is imported..

13 Sonar Display Grid Intensity in dB. Intensity max and min values for the dynamic
range of the Sonar Display Grid are now entered in dB.

14 Sonar Display Grid Enable. A single check button now both shows/hides the Sonar
Display Grid and enables/disables the feature.

15 Range/Bearing to Object. It is now possible to output the range and bearing to an
object to the network. Use Tools→Custom...→Set Parameters, and then select Display
to set the IP-address and UDP port to send these messages to, and see the Manual
for additional information about datagram formats. This output is sent as long as
there is a valid network address set.
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Installation parameters frame
1 Reminder of changed installation parameters.

The operator will now be reminded of any unsaved installation parameter changes
in any of the Installation and Test frames or sub-frames.
Whenever the installation parameters are edited or changed the OK button will
now turn yellow and remain yellow until the parameters are saved or the changes
cancelled.
(Note that the OK will turn yellow only in the moment the text cursor is removed
from the entry field of when a button is clicked or a selection is made.)

A pop-up window will be displayed if unsaved parameters remain and if the
operator, for any reason, still tries to close the Installation and Test frame or select
another echo sounder as active.
The operator must then decide to save the parameters or abandon the changes, by
pressing the Save or Quit button respectively, before being able to continue.
Note

This feature is combined with the installation parameters password handling if
the latter is enabled, see entry on ’Improved installation parameters password
handling’ below.

2 Automatic backup when storing PU installation parameters.
A backup file of the PU Installation and Runtime parameters are generated every
time the OK button is pressed in the Installation and Test frame.
The format of the backup data is the same as for the File →Export PU parameters...
function.
This implies that the backup file can be read by the File →Import PU parameters...
function and used to set the parameters of a sounder.
The backup files are stored in the folder \sisdata\common\backup_settings. The
naming convention of the backup files are as follows:
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Backup_<echo sounder name>_<serial
number>_<YearMonthDay>_<HourMinSec>.txt
e.g. Backup_EM2040_402_20090430_105852.txt
Note that the backup files are never deleted or moved by SIS. This must be
organized and handled outside SIS.

3 Improved installation parameters password handling
When the password handling is enabled for installation parameters (see
Tools→Custom →Set parameters→ Password) it is now no longer necessary to press
the OK button twice to store the changed parameters.
When the password handling is enabled and the parameter editing is completed by
pressing the OK button a password pop-up window is displayed. If the entered
password is correct the parameters will now be saved immediately without the need
to press the OK button a second time.
Note

The text in the OK button will no longer be red when a password is required. I.e. no
visible indications are provided for passwords except the password entry box.

4 External ZDA setup improvement
The External ZDA clock setup has been improved by securing that the Clock source
setting now is dependent on the PU input setting.
The improvement implies that it is not possible to select External ZDA Clock as
clock source from the Installation and Test→PU Communication Setup→Clock Setup
frame before the ZDA Clock has been selected (i.e. ticked) as PU input in the
Installation and Test→Input Setup→Input Formats frame.
I.e. if the ZDA Clock input to the PU is not selected it is not possible to use this
input as a clock source.
When the ZDA Clock selection is changed both the PU Communication Setup and
the Clock Setup tabulators are changed to red to indicate that the operator needs to
check the current clock setup.
Note that in the case that the ZDA Clock input is turned off and the previous
clock source setting was External ZDA Clock the new (fall back) clock source is
automatically set to Active pos. system.
The red tabulator setting is removed when the OK or the CANCEL button is pressed.

5 Log all heights.
The Log all heights feature can now be configured independently for the three
possible positioning systems handled by SIS. The additional quality factors for
which the heights are approved must be defined in a comma separated list and the
list can be different for all three positioning systems, if used.
It is now possible to define extra quality factors for GGA and GGK for which
the heights are approved. When this feature is enabled, height datagrams
(’h’-datagrams) will always be sent from the PU. This feature is implemented for all
multi beam sounders (EM range, except EM 121A).
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This feature can be configured from Installation and Test→Sensor setup→Settings
→Positioning System Settings and Log all heights.

6 New ME70 operation mode.
A new operational mode calledME70 DEFINED has been added for theME70 Pulse
length/Beam density selection in the Installation and Test→ME70 Specific frame. The
new selection implies that the mode is defined by ME70 and not by the SIS operator
(ME70 has an alternative non-SIS control interface called Bathymetric Operator
Station).

7 Corrected PU Ethernet 2 default address information.
The default Ethernet 2 IP address information used for the Attitude Velocity settings
in Installation and Test→ PU Communication setup →Input Setup for Port UDP5 has
been corrected. The new default address is 192.168.1.1 with netmask 255.255.0.0
and port 3000.

Runtime parameters frame
1 GPS and Delayed Heave

A number of existing and new GUI interfaces have been collected in a common
tabulator display in the Runtime parameters frame. The new tabulator is called
GPS and Delayed Heave in accordance with the basic functionality contained. See
image below.
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The existing interfaces that have been moved from their previous separate tabulator
locations are the Javad and Trimble setup interface and the ATH log parameters
interface. In addition to these two existing interfaces two new interfaces are also
included: The RTCM log parameters and the SRH log parameters interfaces. These
two latter interfaces are separately described in theLogging of delayed sensor data
chapter.
Note that the Javad and Trimble setup interface is somewhat different from the
others. The deviation is that it has no Apply or Cancel buttons. This implies that
when the individual Javad and Trimble settings are changed this is communicated
immediately to the affected external Javad and Trimble processes.
The three other interfaces can however be completely configured before the Apply is
pressed whereby the setup is communicated to the relevant external process.

2 The External trigger setting is moved for some echo sounder types.
The aim is to be able to control and check the trigger setting while pinging/logging
is active in connection with use of external synchronisation systems.
The external trigger setting is moved from Installation and Test→Input Setup→Misc.
to the Runtime parameters→Sounder Main→ Transmit Control frame.
The following echo sounders are affected by this move:
• EM 122
• EM 302
• EM 710
• EM 2040
• EM 3002
The legacy echo sounders (i.e. EM 120, EM 300, EM 1002, EM 2000, EM 3000)
retain the External trigger setting in the Installation and Test frame as before.

3 Mammal protection for EM 710.
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The mammal protection feature, previously available for the EM 122 and EM 302
echo sounders, has now also been included for the EM 710 echo sounder.
The feature is located in the Runtime parameters→Filter and Gains frame:

4 Max. Ping Freq. moved to Transmit Control.
In connection with the previous change the Max. Ping Freq. (Hz) setting is
moved from Runtime parameters→Sounder Main →Depth Settings to Runtime
parameters→Sounder Main→ Transmit Control where it naturally belong.
The following echo sounders are affected by this change:
• EM 710
• EM 2040

5 Changed parameter ranges
• EM 3002: Runtime parameters→Advanced param.→TVG ramp level. Valid range

for the ramp level is changed from old range –8—8 to the new range –8—15.
• ME 70: Runtime parameters→Simulator→Parameters for Scope display. Valid

range for the beam number is corrected from old range 0—432 to the new range
0—200.

6 EM 3002 Multi Path Suppression and Soft Sediment
Two new check buttons,Multi Path Suppression and Soft Sediments, have been added
in the Advanced param. frame for EM 3002. See the Manual Control group in the
Runtime parameters→Advanced param. frame:

The check buttons are used to turn the functions on or off. The PU parameters
associated with the functions are MPS for Multi Path Suppression and SOF for
Soft Sediments.
• Multi Path Suppression

Hard reflectors on the shore, distant from the vessel, may cause multi path
detections. These multi path detections may appear as detections on a greater
range or as holes.
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Using Multi Path Suppression may cause the bottom detector to be slightly more
sensible to weaker objects in the water column. Not applicable in detector mode
"normal"

• Soft sediments

In an EM 3002 dual configuration small downward spikes may appear on soft
sediments. The downward spikes are seen on both sides of the vertical, and can
be from 10-50 cm long. Turning Soft Sediment on will eliminate these false
downward spikes.

Water Column frame
1 New functions in the Water Column display window.

Two new convenience functions are available from within theWater Column display
window:
• Force depth
• Set beam number
These functions are enabled/disabled using the Show/Hide menu in the Water
Column display and ticking/un-ticking the Enable Force Depth and Enable Scope
Beam selections respectively.
The depth or beam number used by these functions is set by moving the cursor to the
appropriate point within theWater Column display before activating the functions
using the following mouse and key button combinations:
• Force depth: Ctrl+LeftClick
• Set beam number: Shift+LeftClick
When these button combinations are used the echo sounder will be updated in the
same manner as if the standard Runtime parameters→Sounder Main→ Force depth
(m) button was pressed or the Runtime parameters→Simulator→Beam no. field
was changed.
Note again that these convenience functions must have been enabled in the
Show/Hide menu before the button combinations are recognized

2 Transparency now works on a white background. This resulted in the former
blending modes A and B to be replaced by a single blending mode.

3 The water column display now uses about half as much memory as it did before.
Additionally, the way the water column swath is rendered was changed, reducing
the number of triangles rendered to about half of what it was before. The end result
is half as much memory used and twice the rendering speed.

Stave Display frame
1 Logging of stave data to .all files.

It is now possible to log stave date to the currently opened .all file. To enable this
logging the following conditions must be fulfilled:
• The Stave display frame must be open and remain open.
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• The Logging selection in the Stave display→Show/Hide window must be selected
(i.e. ticked).

• Standard logging must be started/active (i.e. the Logging button in the SIS main
toolbar must be green).

Notice that when no stave data logging is selected an informational message to this
effect is displayed in the top left corner of the Stave display window.

To stop an ongoing stave data logging session the Logging selection in the Show/Hide
window must be deselected or the Stave display frame closed.
When standard logging is turned off stave data logging will also be off.
When the Stave display frame is opened the Logging selection will always be turned
off as default.

Calibration Frame
1 Improved Zoom. Zoom operations using the mouse wheel are now retained such

that these operations are not lost when the apply button is pressed (previously, only
mouse button pan and zoom operations were retained).

2 Improved Pan. It is now possible to pan the display even when it is not in a
"zoomed" state (which will then place the display in a "zoomed" state which can
then be undone using a toolbar button).

3 Select Lines Dialog Box. A dialog box has been created from which the user can
select lines for calibration.
Select Survey Lines dialog box.
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4 Calibration Line Draw Style. It is now possible to choose between three different
draw styles for drawing the calibration data in the calibration frame; LINE, POINTS,
LINE and POINTS. It is possible to set the line width and point size.

5 Corridor Width. The corridor width is now a floating point value (rather than an
integer) and can be set with a precision of 0.1m.

6 View RegionWhen entering Calibration mode (by pressing the ’C’ button), if the
current view region is within the region of the calibration survey (with a small
margin around the survey), the current view region will be retained.

Cross Track Frame
A new scaling mode (named Fixed Delta) has been created that allows the user to specify
two fixed values (i.e. delta values) relative to the center beam depth (an upper value and
a lower value). When this option is specified, the scale will automatically be adjusted
such that the upper and lower depth scale values remain the specified "fixed" distances
away from the center beam depth, as the depth changes.
• It is possible to specify this mode and the two fixed delta value via the Options menu.
• It is also possible to specify this mode and the two fixed delta values by using the

mouse to drag a rectangle in the cross track display.
• The scaling mode can be reset to the previous mode (auto, fixed, etc.) by clicking the

"Reset Zoom" toolbar button.

Sensor Layout Frame
Transparency now works on a white background.
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Input of S-57 formatted chart files
It is now possible to use some of the data in an S-57 chart file as background data in SIS
directly. Coastlines and dryfall (a depthcontour with depth 0.0 meters) are extracted
into KSGPL-formatted files which can be displayed in SIS, and the depthcontours are
also used to construct a 3D terrain model.

How to convert S-57 chart files to SIS input data
1 Select Tools →Custom →S-57 converter and a new window opens up:

2 Press Select s-57 file and select the S-57 file in the file selection dialog window.
3 Choose the map projection from the pulldown menu. The projections listed are the

projections registered in SIS.
4 Press Select output file and choose the output file name.
5 You may want to press Advanced options if you are not happy with the results from

the first run:

Here you can set the parameters defining how the terrain model shall be constructed.
GridEngine multiplier is a factor used to define the grid cell size in the GridEngine.
It should normally 2 or higher.

6 Press Convert and wait. Note that this procedure may take several hours depending
on the parameters. The output is two files, one .ksgpl and one .s57. To use this
data in SIS, follow the procedure below.

How to use the output from S57ToSIS
1 Open File →Import/Export and select KSGPL as the data type. Then simply open

the ksgpl-file generated above and press OK.
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2 Open Tools →Custom →Create grid from ASCII files. Then simply select the .s57–file
as input and create a terrain model.

3 Open File →Import/Export and select Surveys as the data type. Then select the
terrain model created above.

The first procedure must be run only once. The output is one ksgpl-file and one ascii-file
and these files need not be regenerated unless the S-57 file is changed. This means that
this procedure can be run once in the office and the output can be sent anywhere. Also
the generation of grid from ascii-files needs to be done only once. When the terrain
model is created, it can be reused forever. It is thus possible to do this in the office, too,
and simply send the complete terrain model to other users. Note that the projection is
locked once the terrain model is created so everyone who uses this terrain model, must
have the same projection defined.

Logging of delayed sensor data
1 RTCM logging

The SeaPath 300 series from Seatex gives the possibility to log additional GPS
information.
Radio Technical Commission for Maritime Services (RTCM) data can be logged
and subsequently used during post processing to augment and improve the GPS
positioning data. The RTCM logging facility consists of two components: the
RTCM logger process and the SIS RTCM logger interface. RTCM logging can be
performed independent of SIS and the SIS RTCM logger interface.

RTCM logging operation
The following two options for starting RTCM logging are available:
• RTCM logging can be started from the Windows Start→All Program→SIS button.

A RTCM logger process is created and the logging is started immediately.
• When SIS is started an RTCM logger process is also started. The actual logging

operation is started or not depending on the last logger setting used.
Note the following:
• In both the above cases, if an RTCM logging process is already active/running,

no new process is started.
• If the RTCM logging has been stopped by SIS and SIS is terminated, the

logging can be started again, without starting SIS, simply by using the Windows
Start→All Program→SIS button.

• The RTCM logger process is not terminated when SIS is stopped. The
RTCM logger process can be stopped manually from the Windows Start→All
Program→SIS button.

The SIS RTCM logger interface
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When SIS is running the RTCM logger parameters can be configured using the
Runtime parameters→GPS and Delayed Heave interface. The following parameters
can be changed:
• Logging on or off.
• Path to the directory where the logged files are stored.
• Interval (minutes) between consecutive stored files (i.e. file length).
• Port number for the source of data to be logged (according to Seapath

configuration).
Parameters changed by the operator are indicated by a yellow background colour.
The parameters are applied and used by pressing the Apply button whereby the
parameters are transferred to the RTCM logging process. The yellow background
colour is removed.
When applying any parameter changes the current logged file is completed. The
file interval timer is reset. If logging is set to continue a new logged file is started
according to the set parameters.
The Cancel button is used to revert any changes before using the Apply button
When SIS is running the Numerical display frame can display the current RTCM
logging status by selecting the RTCM Log. item. The status is updated when a new
file is created or as a result of changed RTCM logger parameter settings. When
turning logging on for the first time the "ON" indication will not be displayed until
the first RTCM signal is received from the Seapath.
A warning (pop-up) is now issued if no logging input is received by the RTCM
logger within a defined interval, currently set to 20 sec.

RTCM file format.
The name of the logged RTCM file has the following format:
RTCMYYYYMMDD_HHMMSS.rtcm
where the date and time is the current UTC time at the time of file creation.
The format of the information stored in the file is the length of the received signal
(unsigned short, 2 bytes) and then the signal itself.
Note

Each logged .rtcm file is automatically converted to a RINEX (ASCII coded satellite
position data) .08o file as soon as it is completed. This converted file will be used
in the post processing. The original .rtcm file is retained. The naming format of
the RINEX file is YYYYMMDD_HHMMSS.08o where the date and time is fetched from
the first datagram in the file.

2 Seapath Real Heave (SRH) logging
Seapath from Seatex and PosMV from Applanix both allow logging of delayed (true)
heave. Please check with Seatex and Applanix which versions support this feature.
Seapath Real Heave data is delayed by a few minutes coming from the Seapath
due to internal processing. It can be logged by SIS and subsequently used in post
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processing. The SRH logging facility consists of two components: the SRH logger
process and the SIS SRH logger interface. SRH logging must be started and
controlled from the SIS SRH logger interface.
SRH logging operation
When SIS is started an SRH logger process is also started. The actual logging
operation is started or not depending on the last logger setting used.
When SIS is stopped the SRH logger process is also stopped.
The SIS SRH logger interface
When SIS is running the SRH logger parameters can be configured using the
Runtime parameters→GPS and Delayed Heave interface. The following parameters
can be changed:
• Logging on or off.
• Path to the directory where the logged files are stored.
• Interval (minutes) between consecutive stored files (i.e. file length).
• Port number for the source of data to be logged (according to Seapath

configuration).
Parameters changed by the operator are indicated by a yellow background colour.
The parameters are applied and used by pressing the Apply button whereby the
parameters are transferred to the SRH logging process. The yellow background
colour is removed.
When applying any parameter changes the current logged file is completed. The
file interval timer is reset. If logging is set to continue a new logged file is started
according to the set parameters.
The Cancel button is used to revert any changes before using the Apply button
When SIS is running the Numerical display frame can display the current SRH
logging status by selecting the SRH Log. item. The status is updated when a new file
is created or as a result of changed SRH logger parameter settings. When turning
logging on for the first time the "ON" indication will not be displayed until the first
SRH signal is received from the Seapath.
A warning (pop-up) is now issued if no logging input is received by the SRH logger
within a defined interval, currently set to 20 sec.
Note that there is no initial 200 sec. wait for the SRH data to arrive, it is assumed
that the Seapath system is up and running before logging starts (if not the 20 sec.
warning will be issued, one or several times).
SRH file format
The name of the logged SRH file has the following format:
SRH_YYYYMMDD_EPOCSEC.srh
where the date and time is the current UTC time at the time of file creation and
EPOCSEC is the number of seconds since the epoch, 1970–01–01, fetched from the
first signal logged in the file.
The format of the information stored in the file is the length of the received signal
(unsigned short, i.e. 2 bytes) and then the signal itself.
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New logging utilities
These utilities have been added to improve error checking in the EM systems, i.e. to
verify that input from various sensors are correct.
1 Logging of input on SIS sockets.

It is now possible to log data received on some specific SIS sockets.
This feature is primarily intended for support and maintenance activities e.g. to
verify reception of input on sockets and further to validate the received data content.
The logged input data is presented in an hexadecimal format with an additional
ASCII representation where all unprintable characters are represented by a dot.
• Logging alternative 1

This alternative for logging of incoming data on a SIS socket is based on the use
of an separate program — the SIS Data Logger:

The program is started from Tools→Custom...→SIS Data Logger.
The program will send a command to the relevant socket for starting and stopping
logging. When logging is active the data received on the SIS socket will be
re-transmitted out on another socket and received by the logger program. The
logger program is responsible for decoding, displaying and storing the data.
In contrast to alternative 2 below the operator may now get a running update of
the received data in the display while the data is being logged.
The following input parameters and controls are available:
– Host: This is the IP address of the HWS where SIS is residing. Currently this

should always be the 127.0.0, i.e. the SIS Data Logger program must always
run on the same computer as SIS.
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– Port: This is a drop down list of some fixed SIS sockets. In addition the user
may manually enter a SIS socket, however see the ’Some remarks on SIS
sockets’ paragraph below before using this possibility.

– Use default storage:
When selected (ticked) a predefined set of storage options are used:
• The default directory is:

...sisdata/common/maintenance.
• The default file name is:

SIS_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the
user to select an alternative storage location and a file name. Note that if
the file already exists the new logged information will be appended to the
existing file.

– Log File: This element contains the currently selected storage folder and is
used for display only.

– Log button. The logging operation is turned on and off on the set socket
using the log button.
When logging is active all user selections are inactive (i.e. gray coloured). To
change the host and port settings as well as the storage settings the logging
must be turned off.

– Options→Show Datagram Prefix is used to turn the info. line printed at the
head of each datagram packeton or off.
The info. line contains packet size and a time tag.

• Logging alternative 2
This alternative is a low level solution based on internal SIS functionality for
decoding and storing of received data. No running update of logged data is
available. This is in contrast to alternative 1 which uses an external program
for this purpose.
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The logging activity is started or stopped by sending the relevant socket a
command message.
A perl script, portlog.pl, has been implemented to assist the operator in sending
these commands. The portlog.pl script is found in the SIS installation ...bin
directory.
To run the portlog.pl script open a command window and start the script using
the following syntax:
portlog <port no> <ON or OFF> <dir name> <file name>

Where:
• <port no> is the SIS port to log
• <ON or OFF> turns logging on or off respectively.
• <dir name> is optional. This is the directory used to store the logged file.
• <file name> is optional. This is the name of the logged file.
e.g.: portlog 4001 ON

If the directory and/or file names are omitted the following default values will
be used:
• The default directory is:

...sisdata/common/maintenance.
• The default file name is:

SIS_Input_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

Some remarks on SIS sockets:
Note that the sockets used by SIS are of two types: Fixed sockets used by invariant
SIS modules (like SIS main GUI, CCU etc.) and sockets allocated dynamically
when new echo sounders are detected for the first time. In some cases the operators
may also specify ports dynamically for e.g. logging purposes.
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The former (fixed) type may uses permanently allocated port numbers whereas
the latter type uses port numbers allocated sequentially from a set start point (e.g.
16000 currently).
The following are some standard fixed and explicitly defined port numbers:
• Port 4001 is used by the SIS module called CCU for receiving messages from

other SIS modules and in addition the following external input:
• SSP datagrams (i.e. S00 – S53 currently) containing sound velocity and CTD

profiles.
• $KSSIS,80 with sound velocity at transducer
• $ATIDE datagrams with tide
• R20 remote datagram.

• Port 4002 is used by SIS main GUI for receiving messages from other SIS
modules and in addition the following external input:
• R00, R10, R12 remote datagrams for controlling SIS pinging and logging.

• Port 5602 is used for Applanix PosMV TrueHeave logging. See Runtime
parameters→GPS and Delayed Heave.

• Port explicitly defined by user for Seapath Real Heave logging. See Runtime
parameters→GPS and Delayed Heave.

• Port explicitly defined by user for Seapath RTCM logging. See Runtime
parameters→GPS and Delayed Heave.

Note

Dynamically allocated port numbers associated with specific echo sounders are
defined in the SIS database and requires specialist knowledge to be found. They are
therefore as a consequence omitted in this description.

2 Logging of sensor input on PU sockets.
It is now possible to log data received on the sensor input sockets in the PU.
This feature is primarily intended for support and maintenance activities e.g. to
verify reception of input on PU sockets and further to validate the received data
content.
The logged input data is presented in an hexadecimal format with an additional
ASCII representation where all unprintable characters are represented by a dot.
Logging of PU sensor input is only available on the new generation of echo
sounders:
• EM 122
• EM 302
• EM 710
• EM 2040
• EM 3002
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Note

Always remember to turn logging off when finished. No automatic shut off is
provided. Neglecting to terminate logging will increase the load on the PU and
HWS system and the disk capacity for storage of logged data will suffer.

• Logging alternative 1
This alternative for logging of PU sensor input is based on the use of an external
program — the SIS Data Logger:

The program is started from inside SIS using Tools→Custom...→SIS Data Logger.
The program will send a command to the relevant PU for starting and stopping
logging. When logging is active the PU will transmit the data from the sensor
input out on a port received by the external program. The external program will
be responsible for decoding, displaying and logging the data.
In contrast to alternative 2 the operator may now get a running update of the
received data in the display while the data is being logged.
The following input parameters and controls are available:
– Select Echo Sounder: This drop down list will contain the currently started

echo sounder(s) only. (It is only possible to log on echo sounders that have
been started by SIS).

– PU Sensor Port: The PU sensor input port to log from. The possible port
selections are normally the same as listed in the top row in PU sensor
status→PU sensor input status frame.
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– Use default storage:
When selected (ticked) a predefined set of storage options are used:
• The default directory is:

...sisdata/common/maintenance.
• The default file name is:

PU_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the
user to select an alternative storage location and a file name. Note that if
the file already exists the new logged information will be appended to the
existing file.

– Log File: This element contains the currently selected storage folder and is
used for display only.

– Log button. The logging operation is turned on and off using the log button
whereby all necessary logging information is sent to the currently selected PU.
When logging is active the all user selections are inactive (i.e. gray coloured).
To change the PU sensor port setting and the storage settings logging must
be off.

– Options→Show Datagram Prefix is used to turn the info. line printed at the
head of each datagram packet on or off.
The info. line contains packet size and a time tag.

• Logging alternative 2
This alternative is a low level solution based on internal SIS functionality for
decoding and storing of decoded data. No visual update of the decoded stored
data is provided. This is in contrast to alternative 1 where a separate program is
used giving a running update when logging.
The operator interface for controlling this alternative 2 is located in the PU sensor
status →PU sensor input logging frame:
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The PU sensor input logging interface is enabled and displayed using the following
key combination for the above listed type of echo sounders:
Shift+Ctrl+Alt+RightMouseButtonRelease:

The following input parameters and controls are available:
– Port: The PU sensor input port to log from. The possible port selections are

normally the same as listed in the top row in PU sensor input status interface.
– Use default storage:

When selected (ticked) a predefined set of storage options are used:
• The default directory is:

...sisdata/common/maintenance.
• The default file name is:

PU_Input_yyyymmdd_hhmmss.log
where the date and time is the UTC time when logging is started.

When the operator un-ticks this selection a pop-up is displayed allowing the
user to select an alternative storage location and a file name. Note that if
the file already exists the new logged information will be appended to the
existing file.

– Log folder: This element contains the currently selected storage folder and is
used for display only.
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– Log button. The logging operation is turned on and off using the log button
whereby all necessary logging information is sent to the currently active PU.
The button colour and text reflects the current logging status:
• Red: Not logging.
• Green: Logging.
When logging is active the Port selection and Use default storage tick button
is inactive (i.e. gray coloured). To change the PU sensor port setting and the
storage settings logging must be off.

Note

The maximum log file storage size is 2Gb. If this limit is reached logging to
file stops.

Tools Menu
1 Native support for AML Micro SV, Micro SV&P, Micro SV&P and Valeport Mini

SVS has been added
These probes can now be used directly by SIS without changing any settings in
“SetParameters”.

2 DBMaintenance. It is now possible to recreate the SIS Database from the
DBMaintenance application
Select “Reinit DB” from the File menu to recreate the database. Note that all
settings will be lost.

Other
1 The online help in SIS now displays the latest operator manual in Windows help-file

format.
2 Test of correct checksum in R-datagram when starting new lines.

It has been noticed that some PU’s (e.g. EM 300) in some instances may send an
R-datagram with a faulty checksum. Any such datagrams are now disregarded when
starting a new line and the PU is asked to re-send the necessary information (i.e. the
I, U and R datagrams are always included at the start of a new logged line).

3 Pop up messages. The internal message number is shown in brackets at the end of
messages displayed in pop up messages.

4 A pop-up message is displayed when the Grid Engine is running low on memory.
The user is asked to create a new survey and remove the current survey. Creating a
survey with larger grid cell size may help on the problem.

5 New survey frame. A check has been added for projection when selecting a new
survey template.

6 EA single beam position.
When using EA singlebeam echo sounders with SIS the received position
information was not displayed in the SIS Helmsman frame or in the Helmsman
application (started via the Windows start button).
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This has now been corrected.
7 Improved SIS dusk and night display.

All icons in the SIS frames are now displayed with the correct dusk or night settings.
This will avoid any glaring screen points in low light conditions.
Note that some Windows controlled GUI elements, like the cursor hourglass or
cross, still is outside SIS control. See relevant entry in chapter Limitations on
page 42 for more information.

8 SVP editor
In the raw file editor it is now possible to add and/or multiply the values in selected
columns.

Add and/or multiply the values in selected rows.
First select the rows you want to change, then press Add and/or multiply....
This window appears:
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Change the values in the selected rows.
There are two algorithms to choose from: either multiply the value in the cell and
then add a value, or add the value first and then multiply the result. You choose
which one by pressing the button Apply behind the algorithm. Press Back/Close
when finished.
In the raw file editor a new line of buttons have been added.
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The operator can define a macro by pressing the button Define macro. Then the
operator may delete the current macro, selected in the menu to the left, or he may
define a new macro. It must be given a unique name, then choose the split-character
and then define the list of columns to use. The list is the columns to keep, in correct
order.

Pressing Run macro will execute the selected macro on the current file, and the
result will be displayed in a list. When using macros, there is a check that all items
in the list are floating point numbers, which means that cells containing text will be
removed automatically.

9 The version compatibility check is removed for the legacy EM echo sounders.
The compatibility check between PU and SIS software has been removed for the
following echo sounders:
• EM 120
• EM 300
• EM 1002
• EM 2000
• EM 3000
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The PU software for these echo sounders will not change.
10 Version compatibility test report.

A compatibility test between the SIS and PU software is performed at the start-up
of an echo sounder. The legal version combinations (i.e. version sets) of the SIS
and PU software are listed for each echo sounder type in a file called version.txt
supplied with every SIS installation and PU updrade.
The report from this compatibility test will now be with reference to the version set
in the version.txt file with the least number of divergences and not to the most
recent version set.

11 Bug Fix: Corrected SIS crash when SIS is controlled remotely (e.g. by EIVA).
This problem was due to a un-handled case in the software where the operator is in
the process of setting a new survey line count value and a remote Rxx (e.g. R10)
datagram is received before the operator has completed the operation. A conflict
occurred when the same text field (i.e. Line cnt.) was updated. This is now corrected.

12 Bug Fix: Corrected SIS crash when disk is missing or non-existing storage location.
There has been a problem with SIS crashing when a disk containing e.g. grids has
been removed for backup etc. and not being replaced. Also, when a new survey was
specified a non-existing storage location could be entered resulting in a crash.
These problems have been corrected by checking file accessibility before using a
storage location and only allowing survey paths etc. to be defined using a browse
button working on existing file hierarchies.

13 Bug Fix: Corrected problem using more than two decimals in the sound speed
profile.
The PU uses only two decimals for the depth parameter in the sound speed profile.
This implies that the depth resolution must be 1 cm or coarser. If the sound speed
profile contains more that two decimals a situation may occur where two or more
depths are equal when the depths are reduced to two decimals in the PU. To avoid
this problem SIS does a check of the sound speed profile before it is used. An error
message of the following content is displayed if this problem is detected:
Depth values less than 1 cm apart are found in the selected sound speed profile. The
profile will not be used
The operator must then correct the reported problem in the sound speed profile
before the profile may be re-applied.

14 Improved ping mode licence handling for EM 710.
In a situation where the licence settings are changed in an active running SIS system
(e.g. by swapping a licence dongle with another) the EM 710 ping mode setting
would not be updated unless a Runtime parameters frame was already opened.
This problem has now been corrected.

15 More convenient default button selections in pop-ups.
The default button selection in some dialogue pop-ups, e.g. confirmation windows
etc., has been set to a more sensible choice.
Note that not all dialogue pop-ups etc. has been evaluated at this stage.

16 Default storage path for saved messages.
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The default storage paths for error, warning and information messages logged by
the SIS Message service system and subsequently stored to disk by the operator or
automatically by SIS are:
• .../sisdata/common/message

• .../sisdata/common/message/auto

respectively.
Note that the ’File name’ entry field in the Message service frame can not be used
directly for input of a storage path and file name. The operator has to use the [...]
button to set the path and file name.

17 The algorithm for calculation of the mean absorption coefficient down to a specific
depth has been corrected.
The absorption coefficient values prior to the correction would be somewhat smaller
than nominal but, noticeable mainly only for deeper waters and higher frequencies.

18 Helmsman Display. An error when calculating SOG and COG in the Helmsman
Display frame has been fixed.
SOG and COG are now calculated correctly.

19 Grid Engine Restart. It is now possible to restart the HDDS and GridEngine
processes in case they malfunctions
This makes it possible to restart the gridding process without losing logged data.
A small gap in the grid will be noticed, but if importing the raw data, the gap will
be gone.

20 License Server. The SIS License Server now runs as a Windows Service. This means
that the license server is started when the PC is started and not when the user logs in

21 Bug Fix: Geographical Display: Ships Heading. Ships heading was displayed
incorrectly in some (unusual) situations.

22 Bug Fix: Geographical Display: Inspection Mode. Certain operations caused the
inspection mode button to be unset.

23 Bug Fix: Sensor Layout Display. Colors are now read from the database correctly.
24 Bug Fix: Watercolumn Display. If greyscale was selected in water column and you

opened another module in the same frame and went back to watercolumn you got
some strange colors in the water column.

25 Bug Fix: Watercolumn Display. The Water Column display did not take into account
the "Waterline" parameter (WLZ). This caused a mismatch in the depth shown in
the Water Column and the Cross track displays.

26 Bug Fix: Watercolumn Display. When pressing the "Auto once" button, the display
should keep the 1:1 axis scaling.

27 Bug Fix: Watercolumn Display. The Water cloumn display did not take into account
the "TVG offset" parameter in the datagram.

28 Bug Fix: Depth indication. Correction of faulty depth indication in display and
distributed messages.
In some situations the depth displayed in the Numerical display frame and in the SIS
Depth Status bar was faulty. This also affected messages containing the depth which
was distributed externally e.g. KSSIS_31 and NMEA DPT.
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29 Bug Fix: Closed database connections in the Grid Engine after use to prevent
multiple postgres connections that may have caused the PC to run out of resources
and preventing new database connections.

30 Bug Fix: Terrapos_Manager, runTerrapos and RTCMLogger. Terrapos_Manager :
database lookup for terrapos path, assumed the path existed, but it doesn’t always.
Creates it if it doesn’t exist. Also, changed calls to mkdir() to mkdirs(), to be sure
that lower lvl folders are also created. runTerrapos : There was in an instance
an attempt to read outside memory, in a function to search for a word in a path
(fileOperations.cpp — findDir). Fixed this.

31 Helmsman Display. It is now possible to change the NMEA talker Identifier for the
APB message. In order to change the ID, enter a two letter string in Set Parameters,
→Autopilot — NMEA APB Talker Identifier

32 Depth Output. It is now possible to change the NMEA talker Identifier for the DPT
message. In order to change the ID, enter a two letter string in Set Parameters,
→Sensor Options— NMEA DPT Talker Identifier

33 For sub buttom profiler, when creating SRV datagrams, a field containing ping
duration is added (EMD) for EM 120, EM 300, EM 1002, EM 2000, EM 3000 and
EM 3002. Earlier this would only work for EM 710, EM 122, EM 302 and EM 2040.

34 Fixed a bug where Tomcat would sometimes not start.

Known issues
1 Changes that have been made to the show/hide settings in all tear-off windows are

lost every time a frame is opened, closed, or switched in the SIS Main Window or
when the stored window setup in the SIS Main Window is changed (by select a new
window setup from the leftmost combo box on the Main toolbar).

2 In some of the pages in the online-help figure and formulas do not show up. Please
take a look in the Operator manual in pdf format instead. Can be found from
START→All programs→SIS→SISHelp

3 Request Datagram. SRV and NMEA_MDM can only be set to send to one instance
per echo sounder. The rest of the datagram can be send to many instances.

4 Calibration and problem finding raw data. If raw data is copied from a DVD the file
name may be converted to upper case. If this data is imported to SIS and used for
calibration the calibration module has problem to find the raw data files. Renaming
the files to an.all extension (lower case) solves the problem.

5 Sound velocity Probes. The AML Micro probe has to be configured to disable date
and time output for SIS to be able to read it. Before SIS uses the probe the first time.
Start HyperTerminal and attach to the probe and do the setup:

Setup of AML Micro Probe
• Command: SET SCAN TIME [SE SC T]

This command enables the displaying of time during a data scan.
• Command: SET SCAN NOTIME [SE SC NOT]
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This command disables the displaying of time during a data scan.
• Command: SET SCAN DATE [SE SC DA]

This command enables the displaying the date during a data scan.
• Command: SET SCAN NODATE [SE SC NOD]

This command disables the displaying of the date during a data scan
6 SVPLogger is a program started from SVPEditor which can log data from Morse

and AML probes to construct sound speed profiles. The communication with the
probe is rather unreliable over the serial line. If there is no contact with the probe,
go to the main toolbar in SIS and open Tools →External sensors. Then disable and
enable the svp probe to restart it. This will bring the probe back on line again.

7 Time Offset. In the Installation and Test→Clock Setup it is possible to use the Offset
to adjust the echo sounder clock to a local time zone. If a local time zone is set, there
are restrictions: "Time to use" for active positioning must be set to "System". If not,
no data will be displayed in the geographical view. The data it self will be correct
disregarded the selected "Time to use". The problem is that SIS will not take the
time offset into account when reading position time tags.

8 Tools→External sensors. If any changes are made to the communication protocol for
the serial line connected to the sound speed probe, the sound speed probe should be
restarted to make sure the new parameters are in effect.

9 In the Geographical View, if a LOD value is manually chosen be careful not to zoom
too far out with a low value, use of LOD auto is recommended. A large area with
a low LOD value requires much computer memory.

10 Run defragmentation of the hard disk(s) to achieve a large region of continuous
disk space.

11 When generating or editing a sound velocity profile (.asvp files) make sure that no
additional empty lines are present after the last profile item.

12 Some information, warning and error messages may refer to echo sounder type 850.
This is the same as the ME70 echo sounder.

13 In the SVP Editor the File→Send primary SVP to echo sounder is not yet operational.
14 If the database has been deleted, an error may occur if the operator tries to load a

survey with a user defined projection. Remember to put the user defined projection
back into the database and then open the survey.

15 Remote helmsman. A plan or grid must be transferred before activating a line in
order to properly display the activated line.

16 Export of data from SIS. The file SIS_Neptune.rules created when exporting
Neptune Rule from surveys logged with EM 3002Dual contains severe errors, and
should not be imported into Neptune. All beams from head 2 are misplaced.

Limitations
1 When exporting data from SIS, the residue is always 0 if no realtime processing has

been done. This is because no best-fit plane is calculated if processing is off, and
then the residues are not computed either.

2 EM 3000 Dual head. SIS can not operate on head 2 only.
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3 The Auto reload in the Geographical windows should not be set lower than 10
seconds.

4 Absorption coefficient files for all frequencies used by the supported echo sounders
must always be available, except for EA 400, EA 600 and EM 121 A. These files
are made automatically by SIS for all Sxx datagrams received except for S13, S23,
S33, S43 and S53. When using these latter datagrams it is the responsibility of
the operator to supply data for all frequencies, see the Operator manual for more
information.

5 Remote datagrams R11 and R13 are not implemented. Also the parameters ROP,
SID, PLN, PLL and COM defined in the remote datagram format definition are not
used with one exception; PLL is used in R12.

6 Running many overlapping lines with high density (EM 3002D, approx. more than
five lines at 20 meters depth or shallower) with small grid cell size (less than 50cm),
may cause the update of the grid and realtime depth to lag behind the ship symbol.

7 A popup box saying that the GridEngine is not running seems to appear even when
the GridEngine is working properly. Please verify that no data is coming from the
GridEngine (zoom or pan in the Geographical window) before taking action.

8 Helmsman’s display. If a new survey is created in SIS the operator has to chose
transfer grid in the planning module to get the new survey displayed in the
Helmsman display.

9 When using the program CSV2ASVP to convert SmartTalk csv-files to .asvp
sound speed files, note that csv2asvp will fail if the csv-file from SmartTalk is not
formatted correctly. The operator may have to edit the csv-file manually to remove
invalid lines.

10 C-MAP background maps in Geographical Window may cause SIS to crash under
these circumstances: If a projection other than Mercator is used, that projection
may be defined in a limited geographical area (an UTM projection is such a
projection). At startup, SIS may receive a position datagram at the geographical
position 0,0 where the projection may not be valid. If C-MAP is in use, SIS may
hang and must be restarted. The same can occur if SIS receives an invalid position
during logging. To avoid this, enable the spike filter for positions in the Database
parameters (Tools→Custom...→Set Parameters), or do not use Follow ship in the
Geographical window.

11 When using GGA_RTK alarms may not occur if RTK reference signals are lost.
12 Day/night modes have been improved, but are not finished yet.

Some graphical elements are still not converted, this concerns e.g. icons in the file
and directory selection pop up frames and programs/functions started from Tools
→Custom menu etc.

Grid Engine
The Grid Engine and SIS communicate on the network. On Windows the name of the PC
running SIS is put into the PC host file to get the communication work well. In order
to avoid problem with enabled network cards that are not in use. On Linux any unused
network cards must be manually disabled.
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The Grid Engine uses two different grids, one called Processing grid and the other is
called Display grid. The Processing grid has a user defined resolution of its grid cells,
and the user must define how many cells to keep in memory at one time. This is done
by specifying the number of grid cells in x and y direction for the Processing grid. A
maximum of nine Processing grids are then stored in memory at any time.

The Display grid is what the user actually sees. The Display grid is organized in a
hierarchical tree structure called levels. The grid cell size of Level 0 of the Display grid
is the same as the grid cell size of the Processing grid, so Level 0 Display grid will
display everything from the Processing grid. Level 1 in the Display grid is computed
from four grid cells of Level 0, Level 2 is created form four cells of Level 1 and so on.
All this is taken care of by the GridEngine.

In the SIS operator manual the advice for the grid engine parameters are: “The parameter
Grid Cell Size multiplied with the number of Grid Cells should then be approximately
the expected swath width”. For a survey with changing swath width the maximum
swath width should be used when covering a large survey area. If surveying a small area
with a moderate amount of data a smaller value can be used for the grid cell size and
in this way achieve a more detailed grid.

A large survey area can be divided into smaller areas. Copy the files from the previous
survey track folder, \sisdata\grids\”survey name”\tracks to the new survey tracks
folder. In this way the coverage files shows which areas that are already surveyed.
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